Build V8 Javascript Engine under Ubuntu

Standard

Remember that this method (using scons) is deprecated. Btw, go ahead to get instructions.

#######################################################
# WARNING: Building V8 with SCons is deprecated and   #
# will not work much longer. Please switch to using   #
# the GYP-based build now. Instructions are at        #
# http://code.google.com/p/v8/wiki/BuildingWithGYP.   #
#######################################################

Instructions:

# install dependencies
sudo apt-get install libc6-dev-i386 subversion scons libreadline-dev

# sync svn
svn co http://v8.googlecode.com/svn/trunk v8
cd v8/

# run scons, adding option arch=x64 only for x64 architectures
scons console=readline d8

# compile shell
g++ ./samples/shell.cc -o v8-shell -I include libv8.a -lpthread

# be happy
./v8-shell

2 thoughts on “Build V8 Javascript Engine under Ubuntu

  1. I’m not sure exactly why but this blog is loading very slow for me. Is anyone else having this problem or is it a problem on my end? I’ll check
    back later and see if the problem still exists.

Leave a Reply

Fill in your details below or click an icon to log in:

WordPress.com Logo

You are commenting using your WordPress.com account. Log Out / Change )

Twitter picture

You are commenting using your Twitter account. Log Out / Change )

Facebook photo

You are commenting using your Facebook account. Log Out / Change )

Google+ photo

You are commenting using your Google+ account. Log Out / Change )

Connecting to %s